SAML身份验证相关的错误信息

文章编号:020450

本文介绍设置SAML身份验证时显示错误页面时的对策。

SLASH_SA01

私信
未找到登录名与SAMLResponse内的NameID一致的用户。
原因
在cybozu.cn中,不存在登录名与SAMLResponse内的NameID一致的用户。
处理方法
  • 请更改Identity Provider(IdP)的设置,并将用于识别用户的元素设为NameID。
  • 与NameID相关联的值必须同cybozu.cn的用户的登录名称保持一致。

SLASH_SA02

私信
没有与SAMLResponse相对应的AuthnRequest。
原因
在以下情况会发生该错误。
  • 一个会话发出多条SAML请求。
    例:
    • 在同一个Web浏览器的多个标签页进行SSO。
    • SSO后,点击Web浏览器上的返回按钮,并尝试打开cybozu.cn的终结点URL。
  • 执行IdP Initiated的SSO。
处理方法
  • 请避免用同一个对话发送多个SAML请求的操作。
  • 请更改IdP的设置,并执行SP Inidiated的SSO。

SLASH_SA03

私信
请求参数中未包含SAMLResponse。
原因
IdP向cybozu.cn发送的请求参数中没有SAMLResponse。
处理方法
请检查SAMLResponse的发送是否受到阻碍。

SLASH_SA04

代码
SAMLResponse无效。
原因
IdP向cybozu.cn发送的请求参数中没有SAMLResponse。
处理方法
请重新检查一下验证结果为Failed的项目的设置。
也可参考如下信息。
确认SAMLRespose的验证结果

SLASH_SA05

代码
HTTP方法不正确。请将HTTP方法设置为POST。
原因
用于发送SAML应答的HTTP方法非HTTP POST Binding。
处理方法
  • 请更改IdP的设定,使用HTTP POST Binding发送SAML应答。
  • 请在代理服务器等处确认HTTP方法是否变成了POST以外的内容。

SLASH_FA01

代码
SAMLResponse处理失败。
原因
发生了意外的错误,无法处理SAMLResponse。
处理方法
请咨询技术支持。
咨询方法