Cannot Extract a Zip File Containing a Client Certificate
This page provides troubleshooting information related to client certificates of Client Certificate Authentication. The troubleshooting shows you solutions when you fail to extract a zip file.
The File Name of a Client Certificate Is Garbled
Cause
The login name of the user to whom a client certificate was issued contains a multi-byte character, such as Kana, Kanji, or full-width alphanumeric characters.
Solutions
Perform one of the following actions:
- Extract the zip file on a PC running a non-Windows operating system.
- Use software that can extract zip files.
Example of Software That Can Extract Zip Files - Change the login name of the user to alphanumeric characters, and reissue a client certificate and then download the zip file again.
Extraction of Zip Files Fails
Cause
The login name of the user to whom a client certificate is issued meets any of the following conditions.
- The login name exceeds 100 characters.
- The login name is identical to one of Windows reserved device names.
- The login name starts with a Windows reserved device name + ".".
Solution
Perform one of the following actions:
- Extract the zip file on a PC running a non-Windows operating system.
- Use software that can extract zip files.
Example of Software That Can Extract Zip Files - Change the login name of the user to less than 100 characters, and reissue a client certificate and then download the zip file again.
Example of Software That Can Extract Zip Files
Customers are responsible for using the following software.
- 7-Zip
- WinZIP
- WinRAR